Commit 1a7295d5 authored by remy's avatar remy
Browse files

Initial commit with cluster ISE-M modulefiles

parent d9e63c4d
#%Module######################################################################
#
# R-3.0.3 modulefile
#
proc ModulesHelp { } {
puts stderr "This modulefile defines the library paths and"
puts stderr "include paths needed to use R-3.0.3"
puts stderr "The program R-3.0.3"
puts stderr "is added to PATH."
}
set is_module_rm [module-info mode remove]
set R_LEVEL 3.0.3
set R_CURPATH /share/apps/bin/R/R-$R_LEVEL
prepend-path PATH $R_CURPATH/bin/
prepend-path LD_LIBRARY_PATH $R_CURPATH/lib64/R/lib
prepend-path MANPATH $R_CURPATH/share/man
append-path PE_PRODUCT_LIST R-$R_LEVEL
setenv R_LIBS $R_CURPATH/lib64/R/library
#%Module######################################################################
#
# R-3.1.3 modulefile
#
proc ModulesHelp { } {
puts stderr "This modulefile defines the library paths and"
puts stderr "include paths needed to use R-3.1.3"
puts stderr "The program R-3.1.3"
puts stderr "is added to PATH."
}
set is_module_rm [module-info mode remove]
set R_LEVEL 3.1.3
set R_CURPATH /share/apps/bin/R/R-$R_LEVEL
prepend-path PATH $R_CURPATH/bin/
prepend-path LD_LIBRARY_PATH $R_CURPATH/lib64/R/lib
prepend-path MANPATH $R_CURPATH/share/man
append-path PE_PRODUCT_LIST R-$R_LEVEL
setenv R_LIBS $R_CURPATH/lib64/R/library
#%Module######################################################################
#
# R-3.2.0 modulefile
#
proc ModulesHelp { } {
puts stderr "This modulefile defines the library paths and"
puts stderr "include paths needed to use R-3.2.0"
puts stderr "The program R-3.2.0"
puts stderr "is added to PATH."
}
set is_module_rm [module-info mode remove]
set R_LEVEL 3.2.0
set R_CURPATH /share/apps/bin/R/R-$R_LEVEL
prepend-path PATH $R_CURPATH/bin/
prepend-path LD_LIBRARY_PATH $R_CURPATH/lib64/R/lib
prepend-path MANPATH $R_CURPATH/share/man
append-path PE_PRODUCT_LIST R-$R_LEVEL
setenv R_LIBS $R_CURPATH/lib64/R/library
# Modulefiles
Ce dossier contient un ensemble de modulefiles à utiliser pour le cluster ISE-M et MBB
#%Module######################################################################
#
# gcc4.9 modulefile 20150522
#
proc ModulesHelp { } {
puts stderr "This modulefile defines the library paths and"
puts stderr "include paths needed to use gcc4.9"
puts stderr "The program gcc4.9"
puts stderr "is added to PATH."
}
set is_module_rm [module-info mode remove]
set GCC_LEVEL 4.9
set GCC_SUBVER 2
set GCC_CURPATH /share/apps/bin/gcc
prepend-path PATH $GCC_CURPATH/gcc-$GCC_LEVEL.$GCC_SUBVER-bin/bin
prepend-path LD_LIBRARY_PATH $GCC_CURPATH/gcc-$GCC_LEVEL.$GCC_SUBVER-bin/lib64/:/usr/local/lib:/share/apps/lib/libmpc
prepend-path MANPATH $GCC_CURPATH/gcc-$GCC_LEVEL.$GCC_SUBVER-bin/share/man
append-path PE_PRODUCT_LIST GCC
#%Module######################################################################
#
# java1.8 modulefile
#
proc ModulesHelp { } {
puts stderr "This modulefile defines the library paths and"
puts stderr "include paths needed to use java1.8."
puts stderr "You could use BEAST2.2.1 with that version."
puts stderr "The program java1.8"
puts stderr "is added to PATH."
}
set is_module_rm [module-info mode remove]
set JAVA_LEVEL 1.8
#set JAVA_CURPATH /usr/lib/jvm/jre-1.8.0-openjdk-1.8.0.20-3.b26.el6.x86_64/
set JAVA_CURPATH /etc/alternatives/jre_1.8.0_openjdk
setenv JAVA_HOME $JAVA_CURPATH
prepend-path PATH $JAVA_CURPATH/bin/
prepend-path LD_LIBRARY_PATH $JAVA_CURPATH/lib/
append-path PE_PRODUCT_LIST JAVA
#%Module 1.0
#
# OpenMPI module for use with 'environment-modules' package:
#
conflict mpi
prepend-path PATH /usr/lib64/openmpi/bin
prepend-path LD_LIBRARY_PATH /usr/lib64/openmpi/lib
prepend-path PYTHONPATH /usr/lib64/python2.6/site-packages/openmpi
prepend-path MANPATH /usr/share/man/openmpi-x86_64
setenv MPI_BIN /usr/lib64/openmpi/bin
setenv MPI_SYSCONFIG /etc/openmpi-x86_64
setenv MPI_FORTRAN_MOD_DIR /usr/lib64/gfortran/modules/openmpi-x86_64
setenv MPI_INCLUDE /usr/include/openmpi-x86_64
setenv MPI_LIB /usr/lib64/openmpi/lib
setenv MPI_MAN /usr/share/man/openmpi-x86_64
setenv MPI_PYTHON_SITEARCH /usr/lib64/python2.6/site-packages/openmpi
setenv MPI_COMPILER openmpi-x86_64
setenv MPI_SUFFIX _openmpi
setenv MPI_HOME /usr/lib64/openmpi
#%Module######################################################################
#
# perl5.14.2 modulefile
#
proc ModulesHelp { } {
puts stderr "This modulefile defines the library paths and"
puts stderr "include paths needed to use perl5.14"
puts stderr "You could use bioperl with that version."
puts stderr "The program perl5.14"
puts stderr "is added to PATH."
}
set is_module_rm [module-info mode remove]
set PERL_LEVEL 5.14.2
set PERL_CURPATH /opt/perl
prepend-path PATH $PERL_CURPATH/bin/
prepend-path LD_LIBRARY_PATH $PERL_CURPATH/lib/$PERL_LEVEL
prepend-path LD_LIBRARY_PATH $PERL_CURPATH/lib/site_perl/$PERL_LEVEL
prepend-path MANPATH $PERL_CURPATH/share/man
append-path PE_PRODUCT_LIST PERL
setenv PERLLIB $PERL_CURPATH/lib/site_perl/5.14.2/
#%Module######################################################################
#
# python2.7 modulefile 20160115
#
proc ModulesHelp { } {
puts stderr "This modulefile defines the library paths and"
puts stderr "include paths needed to use python2.7."
puts stderr "You could use biopython with that version."
puts stderr "The program python2.7"
puts stderr "is added to PATH."
}
set is_module_rm [module-info mode remove]
set PYTHON_LEVEL 2.7
set PYTHON_CURPATH /opt/python
set PYTHON_SHARE_LIBS /share/apps/lib/python
setenv PYTHONPATH $PYTHON_CURPATH/lib:$PYTHON_SHARE_LIBS/lib/python$PYTHON_LEVEL/site-packages:$PYTHON_CURPATH/lib/python$PYTHON_LEVEL/site-packages
unset-alias python
set-alias python python2.7
prepend-path PATH $PYTHON_CURPATH/bin/:$PYTHON_SHARE_LIBS/bin
prepend-path LD_LIBRARY_PATH $PYTHON_CURPATH/lib/python$PYTHON_LEVEL
prepend-path MANPATH $PYTHON_CURPATH/share/man
append-path PE_PRODUCT_LIST PYTHON2.7
#%Module######################################################################
#
# python3.3 modulefile 20160115
#
proc ModulesHelp { } {
puts stderr "This modulefile defines the library paths and"
puts stderr "include paths needed to use python3.3."
puts stderr "The program python3.3"
puts stderr "is added to PATH."
}
set is_module_rm [module-info mode remove]
set PYTHON_LEVEL 3.3
set PYTHON_CURPATH /opt/python
set PYTHON_SHARE_LIBS /share/apps/lib/python
setenv PYTHONPATH $PYTHON_SHARE_LIBS/lib/python$PYTHON_LEVEL/site-packages:/opt/python/lib/python$PYTHON_LEVEL/site-packages
prepend-path PATH $PYTHON_CURPATH/bin/:$PYTHON_SHARE_LIBS/bin
prepend-path LD_LIBRARY_PATH $PYTHON_CURPATH/lib/python$PYTHON_LEVEL
prepend-path MANPATH $PYTHON_CURPATH/share/man
append-path PE_PRODUCT_LIST PYTHON3.3
unset-alias python
set-alias python python3.3
set-alias python3 python3.3
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment